Problems with radzap: radclient:: failed to get value

Sean Reifschneider jafo at
Mon Dec 19 23:43:13 CET 2011

Hash: SHA1

I'm trying to run a radzap and having no luck.  For example, if I try:

   radzap -d /etc/raddb -N $NAS_IP -P 1 -u las $NAS_IP $NAS_PW
   radclient:: failed to get value
   radclient: Nothing to send.

I've also tried it with the NAS name ("52a2", from /etc/raddb/naslist)
rather than IP:

   radzap -d /etc/raddb -N $NAS_IP -P 1 -u las 52a2 $NAS_PW
   radclient: Failed to find IP address for host 52a2: Success

If I run radwho:

   radwho -ZR -N -P 1 -u las

I get a reasonable-looking:

   User-Name = "las"
   Acct-Session-Id = "000001C1"
   Acct-Status-Type = Stop
   NAS-IP-Address = $NAS_IP
   NAS-Port = 1
   Service-Type = Framed-User
   Framed-Protocol = PPP
   Framed-IP-Address =
   Acct-Session-Time = 239370

However, if I pipe that through radclient:

   radclient -x -d /etc/raddb -f - $NAS_IP acct $NAS_PW

I get the error above:

   radclient:: failed to get value
   radclient: Nothing to send.

I've been trying various combinations of both the output of radwho, and
commands for radclient to log a user out, based on searches on the Internet
including things like sending the "packet of disconnect" (PoD), including
things on this page:

including trying sending to ports 1700 and 3799, using commands like
"disconnect" and "40", using packets like:

      Acct-Session-Id = "000001C1"
      User-Name = "las"
      NAS-IP-Address = $NAS_IP

Using the above packet looks most promising, in that I don't get an error,
it just hangs a few seconds and then fails with "no response from server
for ID 141 socket 3" or similar.

Any pointers on this?

The version of FreeRADIUS is 2.1.10 from CentOS.  There are a couple of
micro version updates I could do, but I didn't see any mention in the
changelog of anything related to this issue being resolved.

Version: GnuPG v1.4.11 (GNU/Linux)
Comment: Using GnuPG with Mozilla -


More information about the Freeradius-Users mailing list