biuro@globeinphotos.com wrote:
I've compared rlm_digest.c from ver.1.0.1 with 1.1.2 and it was appeared that part descibed as "rlm_digest: Converting Digest-Attributes to something sane..." was moved from digest_authorize function to digest_authenticate .
Yes. It can be moved back, if necessary.
It is almost not important but how to handle such situation when I want return few attribute to client but to set values in attributes I need to know what are values in few attributes from Request eg. from Digest-Method.
My suggestion would be to move the code to a common function, and then to call that function from both the authorize && authenticate functions in rlm_digest.c.
P.S As I understand the 'something sane' means that e.g we convert values from Digest-Attributes to Digest-Method.
Yes. Alan DeKok.