New activity for FreeRADIUS (the high performance and highly configurable RADIUS server) ====== Remove jradius dictionary file Arran Cudbard-Bell@2013-02-16T23:28:06Z Files modified: * share/dictionary.jradius Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/b1b63c40f38d37785887a... ====== Fixup Doxygen comments Arran Cudbard-Bell@2013-02-16T23:26:07Z Files modified: * src/lib/dict.c * src/lib/valuepair.c * src/main/valuepair.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/f3144fc769cc287cd5abb... ====== Remove redundant flags and fields from VALUE_PAIR Arran Cudbard-Bell@2013-02-16T23:26:07Z Files modified: * src/include/libradius.h Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/5d7282b656fa1d4e80edb... ====== Use DICT_ATTR for attribute number and vendor number Arran Cudbard-Bell@2013-02-16T23:26:07Z Files modified: * src/lib/valuepair.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/b2f6b3dd0a5781f6f6919... ====== Fixup remaining calls to old xlat functions in evaluate.c and main/valuepair.c Arran Cudbard-Bell@2013-02-16T23:26:07Z Files modified: * src/main/evaluate.c * src/main/valuepair.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/b24e431522646d197ac70... ====== Copy xlat source values when copying attributes Arran Cudbard-Bell@2013-02-16T23:25:48Z Files modified: * src/lib/valuepair.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/10cc9d5fee534f63a3061... ====== Misc whitespace fixes in libradius.h Arran Cudbard-Bell@2013-02-16T23:25:48Z Files modified: * src/include/libradius.h Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/93ae43b11b6036cf9ad7c... ====== Remove pairmake_xlat Arran Cudbard-Bell@2013-02-16T23:25:48Z Files modified: * src/include/libradius.h * src/lib/valuepair.c * src/main/conffile.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/5360c851e0a44607b2855... ====== Modify pair read so that it parses values into a more generic structure, and update it to use the new xlat functions Arran Cudbard-Bell@2013-02-16T23:25:48Z Files modified: * src/include/libradius.h * src/lib/valuepair.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/8ab05193697bff4b660e5... ====== Fixup rlm_sql to use the new xlat functions Arran Cudbard-Bell@2013-02-16T23:25:48Z Files modified: * src/modules/rlm_sql/rlm_sql.c * src/modules/rlm_sql/rlm_sql.h * src/modules/rlm_sql/sql.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/68bf990b72c09c868f59a... ====== Update pairmake_any to call dict_attrunknown Arran Cudbard-Bell@2013-02-16T23:25:48Z Files modified: * src/lib/valuepair.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/0a3cd4ac6a83d2880313d... ====== Rename some arguments to be more consistent in pair compare Arran Cudbard-Bell@2013-02-16T23:25:47Z Files modified: * src/include/radiusd.h * src/main/valuepair.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/bfcae5a58019b69783e9e... ====== Use da->name in pair compare Arran Cudbard-Bell@2013-02-16T23:25:47Z Files modified: * src/main/valuepair.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/1f7d5379bd68e5c536f80... ====== Use da attribute and vendor in paircompare Arran Cudbard-Bell@2013-02-16T23:25:47Z Files modified: * src/main/valuepair.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/59a4271f2a06c4923e7bb... ====== Add radius_xlat_do and rename pairxlatmove to radius_xlat_move Arran Cudbard-Bell@2013-02-16T23:25:47Z Files modified: * src/include/radiusd.h * src/main/valuepair.c * src/modules/rlm_attr_filter/rlm_attr_filter.c * src/modules/rlm_files/rlm_files.c * src/modules/rlm_preprocess/rlm_preprocess.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/d822166298afea19f067e... ====== Remove dependency on pairxlatmove in rlm_rest (it never really needed to use it anyway) Arran Cudbard-Bell@2013-02-16T23:25:47Z Files modified: * src/modules/rlm_rest/rest.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/3d35d8f7a74880d99097a... ====== Fixup dict_valbyattr call in rlm_rediswho Arran Cudbard-Bell@2013-02-16T23:25:47Z Files modified: * src/modules/rlm_rediswho/rlm_rediswho.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/373fdba96711cb660e615... ====== Add pairmark_xlat Arran Cudbard-Bell@2013-02-16T23:25:47Z Files modified: * src/include/libradius.h * src/lib/valuepair.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/408ef6b777bf3224b9733... ====== White space changes in rlm_sql Arran Cudbard-Bell@2013-02-16T23:25:46Z Files modified: * src/modules/rlm_sql/rlm_sql.c * src/modules/rlm_sql/rlm_sql.h Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/752f6f986d2d28a016fb6... ====== Fixup some function documentation in main/valuepair.c Arran Cudbard-Bell@2013-02-16T23:25:46Z Files modified: * src/main/valuepair.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/2cd5d7fe642642fb3d581... ====== Our implementation of DHCP assumes DHCP-Client-Identifier is always a MAC Address Arran Cudbard-Bell@2013-02-16T23:25:46Z Files modified: * share/dictionary.dhcp Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/ed0802c25638f7c900876... ====== Don't bother checking for truncation in rlm_rest, it doesn't work for xlat expanded values anyway Arran Cudbard-Bell@2013-02-16T23:25:46Z Files modified: * src/modules/rlm_rest/rest.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/ff9cf031423116d8bd4ac... ====== Use type int for boolean values, apparently json-c no longer defines it. Arran Cudbard-Bell@2013-02-16T23:25:46Z Files modified: * src/modules/rlm_rest/rest.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/98403c70248bba801395d... ====== Remove rlm_policy from the red hat spec file Arran Cudbard-Bell@2013-02-16T23:25:46Z Files modified: * redhat/freeradius.spec Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/25a1ca234acf06f24b46b... ====== Remove rlm_jradius documentation and dictionaries Arran Cudbard-Bell@2013-02-16T23:25:46Z Files modified: * doc/rlm_jradius * share/dictionary Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/40ca9399fb8f9259e130e... ====== -- This commit summary was generated @2013-02-17T00:00:02Z by lgfeed version 0.00 (https://github.com/arr2036/lgfeed).