commit f26f41c0ee6c562200f4aedbe55bdf083a36bb1b Author: Alan T. DeKok <aland@freeradius.org> Date: Sat Mar 6 15:45:08 2010 +0100 Allow IPv6 to bind to interface with scope. A follow-on to the previous patch. Files changed: src/main/listen.c | 52 +++++++++++++++++++++++++++++++++++++++++++--------- 1 files changed, 43 insertions(+), 9 deletions(-) ====================================================================== commit 5b1ad1b0d1314c00499833126943f53aa36318a7 Author: Alan T. DeKok <aland@freeradius.org> Date: Sat Mar 6 14:26:27 2010 +0100 Add IPv6 "scope" for link-local addresses. Added to fr_ipaddr_t. fr_ipaddr_cmp(), fr_sockaddr2ipaddr(), fr_ipaddr2sockaddr(). Also made ip_hton() call fr_sockaddr2ipaddr() to prevent code duplication. Files changed: src/include/libradius.h | 1 + src/lib/misc.c | 59 ++++++++++++++++++++--------------------------- 2 files changed, 26 insertions(+), 34 deletions(-) ====================================================================== commit 882a4146bd8ed61b1d2044e53744678c209e7343 Author: Alan T. DeKok <aland@freeradius.org> Date: Sat Mar 6 12:40:23 2010 +0100 Check for AF_INET6, not HAVE_AF_INET6 HAVE_AF_INET6 isn't defined, AF_INET6 is. Files changed: src/lib/udpfromto.c | 2 +- 1 files changed, 1 insertions(+), 1 deletions(-) ====================================================================== commit b3a5a8a4dcd123c5b1f926599c5a2cadb08eee11 Author: Alan T. DeKok <aland@freeradius.org> Date: Sat Mar 6 12:13:54 2010 +0100 Work around implementation-dependent shift results uint32 foo = ~0; foo <<= 32; Q: what's foo? A: undefined. Files changed: src/main/client.c | 13 +++++++++---- 1 files changed, 9 insertions(+), 4 deletions(-) ====================================================================== commit 37c5fd7964811f39ba366f80947226dadb5b5a5e Author: Alan T. DeKok <aland@freeradius.org> Date: Sat Mar 6 11:03:33 2010 +0100 Calculate IPv6 netmask correctly. Closes bug #69 Files changed: src/main/client.c | 26 ++++++++++++++++++++------ 1 files changed, 20 insertions(+), 6 deletions(-) ====================================================================== commit 4d849cc53763e28972ecddea79afed016968d6fc Author: Alan T. DeKok <aland@freeradius.org> Date: Sat Mar 6 08:48:06 2010 +0100 Receive CoA packets when they have been separated from parents Otherwise, the code thinks that there is a proxy reply WITHOUT an original reply.. There's still likely a bug, as the CoA request->reply is built BEFORE the original->reply. The post-proxy CoA work should very likely have complete access to the original reply packet type Files changed: src/main/event.c | 12 ++++++++++++ 1 files changed, 12 insertions(+), 0 deletions(-) ====================================================================== commit c8a5624e1f5ea71b564f626337c56b8cfd86a775 Author: Alan T. DeKok <aland@freeradius.org> Date: Fri Feb 26 11:11:02 2010 +0100 Clean up log file handling. Fixes bug #63 We now open the log file from the option parsing (-l file) OR in mainconfig.c. That way, the code in log.c can assume that there is ALWAYS a log file, and it doesn't need to open one. This simplifies log.c substantially. We also moved the syslog "openlog" code from log.c to mainconfig.c This again makes it simpler. On HUP, the hup_mainconfig() function takes care of re-opening the log file. This is so that the log.c functions don't have to do it. Files changed: src/main/event.c | 12 ++----- src/main/mainconfig.c | 82 ++++++++++++++++++++++++++++++++++++++++++------ src/main/radiusd.c | 7 +++- 3 files changed, 80 insertions(+), 21 deletions(-) ====================================================================== commit 9a6edfe42404bb0532a24927cb20180444fd42d0 Author: Alan T. DeKok <aland@freeradius.org> Date: Fri Feb 26 10:31:59 2010 +0100 As posted to the list Files changed: share/dictionary.hp | 3 +++ 1 files changed, 3 insertions(+), 0 deletions(-) ====================================================================== commit 243f3497ed43ba8b3a2ad340c5a3a1e25b03be9b Author: Alan T. DeKok <aland@freeradius.org> Date: Tue Feb 16 17:47:27 2010 +0100 Switch default for acct realms to "no_response_fail" Since accounting packets aren't re-tried, failing one packet over from one server to another isn't a good idea. Files changed: src/main/realms.c | 16 ++++++++++++++++ 1 files changed, 16 insertions(+), 0 deletions(-) ======================================================================