New activity for FreeRADIUS (the high performance and highly configurable RADIUS server) ====== Relax checks on "possible attr names" a bit Alan T. DeKok@2015-04-28T17:59:47Z Files modified: * src/main/parser.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/8ee6d23fdc94fd63aed67... ====== Make LDAP-Group and SQL-Group use paircompare_register_byname() * LDAP-Group and SQL-Group attributes are now dynamically allocated. * You cannot assign values to LDAP-Group or SQL-Group * Only the "sql" module registers SQL-Group. Other modules register "instance-name-SQL-Group", similarly to "ldap". Alan T. DeKok@2015-04-28T17:54:58Z Files modified: * share/dictionary.freeradius.internal * src/modules/rlm_ldap/rlm_ldap.c * src/modules/rlm_sql/rlm_sql.c * src/modules/rlm_sql/rlm_sql.h Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/8800e35a870394dd13e4b... ====== If the LHS is of the form "Foo-Bar", treat it as an attribute This change is necessary to allow backwards compatibility with configs that use LDAP-Group instead of &LDAP-Group, now that it will be dynamically allocated Alan T. DeKok@2015-04-28T17:52:35Z Files modified: * src/main/parser.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/425625b9388a472109033... ====== If LHS is combo-IP, mash the LHS to the type of the RHS Alan T. DeKok@2015-04-28T17:51:59Z Files modified: * src/main/parser.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/c93a05ab80be47372394e... ====== Disallow assignment to dynamic attributes Alan T. DeKok@2015-04-28T17:43:55Z Files modified: * src/main/map.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/9f83224c2491e726995c5... ====== doxygen Alan T. DeKok@2015-04-28T15:58:01Z Files modified: * src/main/exfile.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/401f1c170192e69cf91f6... ====== Make locking configurable, and re-enable detail "locking" Alan T. DeKok@2015-04-28T15:57:40Z Files modified: * src/include/exfile.h * src/main/exfile.c * src/modules/rlm_detail/rlm_detail.c * src/modules/rlm_linelog/rlm_linelog.c * src/modules/rlm_sql/rlm_sql.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/857f5d1d852969f45bbe0... ====== Mark paircompare() attributes which were dynamically created So that the rest of the code can complain if you try to assign something to them. Alan T. DeKok@2015-04-28T15:56:32Z Files modified: * src/include/libradius.h * src/main/pair.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/d8d432c7212759585b958... ====== Register Unix-Group via the new paircompare API Alan T. DeKok@2015-04-28T15:56:30Z Files modified: * src/modules/rlm_unix/rlm_unix.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/b608de69471f08bf13d61... ====== If the thing doesn't exist, we get !*out, and ret == 0 Alan T. DeKok@2015-04-28T15:56:29Z Files modified: * src/main/util.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/7a6bc9418b1c666bff975... ====== Define paircompare_register_byname() Which creates the named attribute. This API ensures that we don't need to have the attributes in the dictionaries. Which in turn means that it's harder for the admin to screw up the configuration Alan T. DeKok@2015-04-28T15:56:27Z Files modified: * src/include/radiusd.h * src/main/pair.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/3dab750291f2afd37b1b8... ====== We don't need to manually unregister the paircompares Alan T. DeKok@2015-04-28T15:56:26Z Files modified: * src/modules/rlm_logintime/rlm_logintime.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/14d5150909e1d115f6329... ====== Remove note. We no longer need to manually unregister xlats Alan T. DeKok@2015-04-28T15:56:24Z Files modified: * src/modules/rlm_expr/rlm_expr.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/ce809c3ded6e4ac483f5f... ====== Sub-attrs as posted to the list. Alan T. DeKok@2015-04-28T12:49:17Z Files modified: * share/dictionary.3gpp2 Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/c2b0e0805e95708a544ff... ====== ATTR_FLAGS should be initialized properly, and not be "static" Alan T. DeKok@2015-04-28T12:46:31Z Files modified: * src/modules/rlm_ldap/rlm_ldap.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/6241c7be08257a65e9a76... ====== sed -ie 's/fr_debug_flag/fr_debug_lvl/' sed -ie 's/debug_flag/rad_debug_lvl/' They're not flags. Prefixing debug_lvl with rad_ makes it clear its part of the server library. So fr_debug_lvl is the library debug level, rad_debug_lvl is the server debug level. Arran Cudbard-Bell@2015-04-28T12:41:40Z Files modified: * src/include/libradius.h * src/include/log.h * src/include/radclient.h * src/include/radiusd.h * src/include/radsniff.h * src/lib/misc.c * src/lib/radius.c * src/lib/tcp.c * src/main/auth.c * src/main/command.c * src/main/conffile.c * src/main/exec.c * src/main/listen.c * src/main/log.c * src/main/mainconfig.c * src/main/map.c * src/main/modcall.c * src/main/modules.c * src/main/pair.c * src/main/process.c * src/main/radattr.c * src/main/radclient.c * src/main/radiusd.c * src/main/radmin.c * src/main/radsniff.c * src/main/radwho.c * src/main/state.c * src/main/threads.c * src/main/tls.c * src/main/tls_listen.c * src/main/unittest.c * src/main/util.c * src/main/xlat.c * src/modules/proto_bfd/bfd.c * src/modules/proto_dhcp/dhcp.c * src/modules/proto_dhcp/dhcpclient.c * src/modules/proto_vmps/vqp.c * src/modules/rlm_digest/rlm_digest.c * src/modules/rlm_eap/radeapclient.c * src/modules/rlm_eap/rlm_eap.c * src/modules/rlm_eap/types/rlm_eap_gtc/rlm_eap_gtc.c * src/modules/rlm_eap/types/rlm_eap_ikev2/ike_conf.c * src/modules/rlm_eap/types/rlm_eap_peap/peap.c * src/modules/rlm_eap/types/rlm_eap_tls/rlm_eap_tls.c * src/modules/rlm_eap/types/rlm_eap_ttls/ttls.c * src/modules/rlm_files/rlm_files.c * src/modules/rlm_ldap/ldap.c * src/modules/rlm_ldap/ldap.h * src/modules/rlm_unbound/rlm_unbound.c * src/modules/rlm_wimax/rlm_wimax.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/01fabb7b8417e708fe278... ====== Formatting Arran Cudbard-Bell@2015-04-28T12:32:44Z Files modified: * src/main/mainconfig.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/27343d0e56f1b6ec5beb3... ====== Merge pull request #981 from qnet-herwin/rlm_perl_document_arrayrefs Added example of multi-value attributes in rlm_perl Arran Cudbard-Bell@2015-04-28T09:14:04Z Files modified: * raddb/mods-config/perl/example.pl Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/8d07fdb1f60460c87ac90... ====== Added example of multi-value attributes in rlm_perl As seen on the mailing list today (subject: "How to Pass multiple Attribute Value Pair of Same Name"), this isn't always clear to the users. Herwin Weststrate@2015-04-28T09:12:05Z Files modified: * raddb/mods-config/perl/example.pl Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/1f312ce1b41aa933bf44a... ====== -- This commit summary was generated @2015-04-29T00:00:02Z by lgfeed version 0.00 (https://github.com/arr2036/lgfeed).