$ touch src/modules/rlm_python/configure.in $ make AUTOCONF src/modules/rlm_python/configure CONFIGURE src/modules/rlm_python/ checking for gcc... gcc ... config.status: creating all.mk CC src/modules/rlm_python/rlm_python.c LINK build/lib/rlm_python.la Very nice. I've been doing massive renaming of module functions, and names in the configure scripts. I missed a few modules the first time around. After some thinking, I created the Make rules which do the work noted above. The result is that it's now much harder to get build failures, even when you're mangling configure scripts! The naming changes were done to avoid the "smurfing smurf" problem. The previous code had a lot of: rlm_smurf_t *smurf; smurf_authenticate() ... etc. With the input for the configure scripts having "smurf_cflags" and "smurf_ldflags". In the interest of removing an abomination from the earth, those functions have been renamed to use a common "mod_" prefix. All modules now have "mod_authenticate", "mod_authorize", etc. The configure / Makefile code has been updated to use mod_cflags, etc. It's just one more item of consistency. It means that there are fewer surprises when editing a module. And few changes to make when creating a new module. Alan DeKok.