New activity for FreeRADIUS (the high performance and highly configurable RADIUS server) ====== Mark zombie alive if it responses to status-server. Fixes #579 Alan T. DeKok@2014-04-05T19:04:29Z Files modified: * src/main/process.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/ba5452f06609df626d279... ====== If we can't originate the CoA request, just free it Alan T. DeKok@2014-04-05T17:52:31Z Files modified: * src/main/process.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/27e12357f0df131cbe0fe... ====== If we're updating a CoA list, auto-create it. Alan T. DeKok@2014-04-05T17:52:31Z Files modified: * src/main/valuepair.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/ece3b2a85636135d80d6a... ====== Put old code back which actually worked... Arran Cudbard-Bell (via Alan T. DeKok)@2014-04-05T17:23:12Z Files modified: * src/main/radclient.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/a8a6e0df9eaf4d79e647f... ====== Whoops... not all regexes are precompiled Alan T. DeKok@2014-04-05T16:14:51Z Files modified: * src/main/evaluate.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/4b74745d56ef02d7f9c89... ====== Allow unpack to take hex data, too Alan T. DeKok@2014-04-05T16:14:50Z Files modified: * raddb/mods-available/unpack * src/modules/rlm_unpack/rlm_unpack.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/8c838d7cceebd976c256c... ====== Remove commented-out code Alan T. DeKok@2014-04-05T16:14:49Z Files modified: * src/include/libradius.h Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/e613b094a944dba28280a... ====== Fix failing tests. Apparently radclient was fixed to not crash, but unittest wasn't. So... make the code identical. Alan T. DeKok@2014-04-05T16:14:43Z Files modified: * src/main/radclient.c * src/main/unittest.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/1d676a78824929b555ae5... ====== Move comment Arran Cudbard-Bell@2014-04-05T13:08:07Z Files modified: * src/lib/debug.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/c04f0dfdb80b89861bd70... ====== Add test for mixing foreaches and regexes Arran Cudbard-Bell@2014-04-05T13:05:40Z Files modified: * src/tests/keywords/foreach-regex * src/tests/keywords/foreach-regex.attrs * src/tests/keywords/if-regex-match Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/842960cf9a09149e1f795... ====== Use STDIN for STDOUT for PANIC_ACTION in travis Arran Cudbard-Bell@2014-04-05T10:20:17Z Files modified: * .travis.yml Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/860379a94d0d6b72ceee1... ====== Fix issues in radlog_init Arran Cudbard-Bell@2014-04-05T10:12:46Z Files modified: * src/main/log.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/ff569326fc139fbbe53ef... ====== Don't call function for 2 lines of code Alan T. DeKok@2014-04-05T05:05:39Z Files modified: * src/main/log.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/f926c7f73a48b928faf08... ====== Move STDIN / STDOUT mangling to radlog_init() Which means fewer global functions that have only one caller, and all of the STDIN / STDOUT mangling is now encapsulated in log.c Alan T. DeKok@2014-04-05T05:00:49Z Files modified: * src/include/log.h * src/main/log.c * src/main/radiusd.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/01feb76ee620b288c7d98... ====== Rename "dont_fork" to "daemon_mode" Positive statements are easier to reason about. This is demonstrated by the redundant "if (dont_fork == false)" checks, and the check for foreground_mode which actually checks for daemon mode. Alan T. DeKok@2014-04-05T05:00:48Z Files modified: * src/main/radiusd.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/f9540b1cbcb4fa80e3239... ====== "signal" is a C library function, not a variable Alan T. DeKok@2014-04-05T05:00:47Z Files modified: * src/main/radiusd.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/f08f02d8ef6bfa7fae79b... ====== Restore stderr/stdout before calling panic_action (if in foreground mode) Rename fr_log_t field dest to dst to match the macros Arran Cudbard-Bell@2014-04-05T01:55:58Z Files modified: * src/include/libradius.h * src/include/log.h * src/lib/debug.c * src/main/command.c * src/main/log.c * src/main/mainconfig.c * src/main/radiusd.c * src/main/unittest.c * src/modules/rlm_unbound/rlm_unbound.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/fec10fd3689eb373ddb03... ====== -- This commit summary was generated @2014-04-06T00:00:04Z by lgfeed version 0.00 (https://github.com/arr2036/lgfeed).