31 Aug
2005
31 Aug
'05
4:34 p.m.
Frank Cusack <fcusack@fcusack.com> wrote:
I personally dislike that, however I have seen other pieces of code that did similar things to avoid casts. Myself, I find it quite hard to read.
I agree. That's why som eheader files do: #define my_foo bar.baz.y.z.foo It breaks some things, but it's easy to read.
Not sure why you'd use uint8_t instead of unsigned char though.
Less typing? Personally, I don't like "unsigned char", as that says to me "unsigned ASCII character". Instead "uint8_t" says "unsigned 8 bits of data". Alan DeKok.