New activity for FreeRADIUS (the high performance and highly configurable RADIUS server) ====== Check for assigning to paircompare() attrs Alan T. DeKok@2015-04-28T18:35:09Z Files modified: * src/tests/keywords/all.mk * src/tests/keywords/radiusd.conf * src/tests/keywords/unix-error Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/5f9c37c2c8c2d94e188a8... ====== note Foo-Bar change Alan T. DeKok@2015-04-28T18:00:47Z Files modified: * doc/ChangeLog Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/1025e56bcd71a51c5dcef... ====== Relax checks on "possible attr names" a bit Alan T. DeKok@2015-04-28T17:59:31Z Files modified: * src/main/parser.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/a5c85128fae25ac9a854f... ====== note recent changes Alan T. DeKok@2015-04-28T17:43:08Z Files modified: * doc/ChangeLog Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/cdbf3a3d172a0ee919c64... ====== Make LDAP-Group and SQL-Group use paircompare_register_byname() * LDAP-Group and SQL-Group attributes are now dynamically allocated. * You cannot assign values to LDAP-Group or SQL-Group * Only the "sql" module registers SQL-Group. Other modules register "instance-name-SQL-Group", similarly to "ldap". Alan T. DeKok@2015-04-28T17:39:09Z Files modified: * share/dictionary.freeradius.internal * src/modules/rlm_ldap/rlm_ldap.c * src/modules/rlm_sql/rlm_sql.c * src/modules/rlm_sql/rlm_sql.h Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/2293292dacad23a237ff2... ====== If the LHS is of the form "Foo-Bar", treat it as an attribute This change is necessary to allow backwards compatibility with configs that use LDAP-Group instead of &LDAP-Group, now that it will be dynamically allocated Alan T. DeKok@2015-04-28T17:36:01Z Files modified: * src/main/parser.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/f613fe3a9cf4e60ef5752... ====== Disallow assignment to dynamic attributes Alan T. DeKok@2015-04-28T16:36:01Z Files modified: * src/main/map.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/fc3dd33db73079ce28042... ====== doxygen Alan T. DeKok@2015-04-28T15:55:45Z Files modified: * src/main/exfile.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/ca4446e80b772157a8469... ====== Make locking configurable, and re-enable detail "locking" Alan T. DeKok@2015-04-28T14:25:44Z Files modified: * src/include/exfile.h * src/main/exfile.c * src/modules/rlm_detail/rlm_detail.c * src/modules/rlm_linelog/rlm_linelog.c * src/modules/rlm_sql/rlm_sql.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/dd2a06aa6ba8d6b819712... ====== Mark paircompare() attributes which were dynamically created So that the rest of the code can complain if you try to assign something to them. Alan T. DeKok@2015-04-28T14:25:44Z Files modified: * src/include/libradius.h * src/main/pair.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/8ab3ba24307d5e7562deb... ====== Register Unix-Group via the new paircompare API Alan T. DeKok@2015-04-28T14:25:44Z Files modified: * src/modules/rlm_unix/rlm_unix.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/54f3016530fe62ecf8846... ====== If the thing doesn't exist, we get !*out, and ret == 0 Alan T. DeKok@2015-04-28T14:25:44Z Files modified: * src/main/util.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/2ad0ad60a9bfd7c3f37aa... ====== Define paircompare_register_byname() Which creates the named attribute. This API ensures that we don't need to have the attributes in the dictionaries. Which in turn means that it's harder for the admin to screw up the configuration Alan T. DeKok@2015-04-28T14:25:44Z Files modified: * src/include/radiusd.h * src/main/pair.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/d4e82d5c8b98c7544fc12... ====== We don't need to manually unregister the paircompares Alan T. DeKok@2015-04-28T14:25:44Z Files modified: * src/modules/rlm_logintime/rlm_logintime.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/ea052244cea11fd0b76aa... ====== Remove note. We no longer need to manually unregister xlats Alan T. DeKok@2015-04-28T14:25:44Z Files modified: * src/modules/rlm_expr/rlm_expr.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/cc686dd15dda77901c798... ====== Ignore exuberant ctags people can generate their own Arran Cudbard-Bell@2015-04-28T13:02:54Z Files modified: * .gitignore Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/4bd03a974967d1790ac7c... ====== Sub-attrs as posted to the list. Alan T. DeKok@2015-04-28T12:49:04Z Files modified: * share/dictionary.3gpp2 Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/200491e6a4629be2432f4... ====== ATTR_FLAGS should be initialized properly, and not be "static" Alan T. DeKok@2015-04-28T12:45:42Z Files modified: * src/modules/rlm_ldap/rlm_ldap.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/444ac5c8c5d5b9d08eba3... ====== Formatting Arran Cudbard-Bell@2015-04-28T12:42:17Z Files modified: * src/main/mainconfig.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/e46534670dfefab1aa746... ====== sed -ie 's/fr_debug_flag/fr_debug_lvl/' sed -ie 's/debug_flag/rad_debug_lvl/' They're not flags. Prefixing debug_lvl with rad_ makes it clear its part of the server library. So fr_debug_lvl is the library debug level, rad_debug_lvl is the server debug level. Arran Cudbard-Bell@2015-04-28T12:40:18Z Files modified: * src/include/libradius.h * src/include/log.h * src/include/radclient.h * src/include/radiusd.h * src/include/radsniff.h * src/lib/misc.c * src/lib/radius.c * src/lib/tcp.c * src/main/auth.c * src/main/command.c * src/main/conffile.c * src/main/exec.c * src/main/listen.c * src/main/log.c * src/main/mainconfig.c * src/main/map.c * src/main/modcall.c * src/main/modules.c * src/main/pair.c * src/main/process.c * src/main/radattr.c * src/main/radclient.c * src/main/radiusd.c * src/main/radmin.c * src/main/radsniff.c * src/main/radwho.c * src/main/state.c * src/main/threads.c * src/main/tls.c * src/main/tls_listen.c * src/main/unittest.c * src/main/util.c * src/main/xlat.c * src/modules/proto_dhcp/dhcp.c * src/modules/proto_dhcp/dhcpclient.c * src/modules/proto_vmps/vqp.c * src/modules/rlm_digest/rlm_digest.c * src/modules/rlm_eap/radeapclient.c * src/modules/rlm_eap/rlm_eap.c * src/modules/rlm_eap/types/rlm_eap_gtc/rlm_eap_gtc.c * src/modules/rlm_eap/types/rlm_eap_ikev2/ike_conf.c * src/modules/rlm_eap/types/rlm_eap_peap/peap.c * src/modules/rlm_eap/types/rlm_eap_tls/rlm_eap_tls.c * src/modules/rlm_eap/types/rlm_eap_ttls/ttls.c * src/modules/rlm_files/rlm_files.c * src/modules/rlm_ldap/ldap.c * src/modules/rlm_ldap/ldap.h * src/modules/rlm_unbound/rlm_unbound.c * src/modules/rlm_wimax/rlm_wimax.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/3f3909e35f2b620944c52... ====== Added example of multi-value attributes in rlm_perl As seen on the mailing list today (subject: "How to Pass multiple Attribute Value Pair of Same Name"), this isn't always clear to the users. Herwin Weststrate (via Arran Cudbard-Bell)@2015-04-28T09:14:42Z Files modified: * raddb/mods-config/perl/example.pl Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/2f9072c230b7800667145... ====== -- This commit summary was generated @2015-04-29T00:00:02Z by lgfeed version 0.00 (https://github.com/arr2036/lgfeed).