New activity for FreeRADIUS (the high performance and highly configurable RADIUS server) ====== Make sql_fetch_row write a pointer to the row instead of setting it inside the handle The rlm_sql_handle should really be an opaque driver specific struct that the rlm_sql module has no visibility into, this is the first step towards that. Arran Cudbard-Bell@2014-11-18T18:41:18Z Files modified: * src/modules/rlm_sql/drivers/rlm_sql_db2/rlm_sql_db2.c * src/modules/rlm_sql/drivers/rlm_sql_firebird/rlm_sql_firebird.c * src/modules/rlm_sql/drivers/rlm_sql_freetds/rlm_sql_freetds.c * src/modules/rlm_sql/drivers/rlm_sql_iodbc/rlm_sql_iodbc.c * src/modules/rlm_sql/drivers/rlm_sql_mysql/rlm_sql_mysql.c * src/modules/rlm_sql/drivers/rlm_sql_null/rlm_sql_null.c * src/modules/rlm_sql/drivers/rlm_sql_oracle/rlm_sql_oracle.c * src/modules/rlm_sql/drivers/rlm_sql_postgresql/rlm_sql_postgresql.c * src/modules/rlm_sql/drivers/rlm_sql_sqlite/rlm_sql_sqlite.c * src/modules/rlm_sql/drivers/rlm_sql_unixodbc/rlm_sql_unixodbc.c * src/modules/rlm_sql/rlm_sql.c * src/modules/rlm_sql/rlm_sql.h * src/modules/rlm_sql/sql.c * src/modules/rlm_sqlhpwippool/rlm_sqlhpwippool.c * src/modules/rlm_sqlippool/rlm_sqlippool.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/f3f9865ec9a8891078590... ====== Add PW_TYPE_NOT_EMPTY and sprinkle it in the SQL module Arran Cudbard-Bell@2014-11-18T18:32:12Z Files modified: * src/include/conffile.h * src/main/conffile.c * src/modules/rlm_sql/rlm_sql.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/f9c61effc6171919837bc... ====== Fix potential race condition when originating CoA requests Arran Cudbard-Bell@2014-11-18T17:09:05Z Files modified: * src/main/process.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/4815970ccd30c707ca7be... ====== Complain if the config has empty strings Alan T. DeKok@2014-11-18T16:18:37Z Files modified: * src/modules/rlm_sql/rlm_sql.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/5ecb4ba7ac00252f32083... ====== Empty strings for queries aren't errors Alan T. DeKok@2014-11-18T16:18:36Z Files modified: * src/modules/rlm_sql/rlm_sql.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/55e42cb11a01bd9205998... ====== Use more descriptive names for the unknown attribute buffers Arran Cudbard-Bell@2014-11-18T06:35:32Z Files modified: * src/include/tmpl.h * src/main/tmpl.c Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/7004e7d9a4fe2e739d401... ====== We can assert map->lhs isn't NULL even when not building with VERIFY_MAP Arran Cudbard-Bell@2014-11-18T04:37:24Z Files modified: * src/include/map.h Commit diff: https://github.com/FreeRADIUS/freeradius-server/commit/b84836e6120bc5588e216... ====== -- This commit summary was generated @2014-11-19T00:00:02Z by lgfeed version 0.00 (https://github.com/arr2036/lgfeed).