CVS log entries from 24.10.2005 (Mon) 08:00:00 - 25.10.2005 (Tue) 08:00:01 GMT ===================================================== Summary by authors ===================================================== Author: aland File: radiusd/src/lib/radius.c; Revisions: 1.167 Author: fcusack File: radiusd/src/modules/rlm_otp/cardops/cryptocard.c; Revisions: 1.21 File: radiusd/src/modules/rlm_otp/otp_cardops.c; Revisions: 1.41, 1.40 ===================================================== Combined list of identical log entries ===================================================== Description: Update minauthtime handling for event-only cards to fix a bug in the sync_response loop where authtime always equals minauthtime, and so the 0th event (or, all events earlier than minewin, usu. 0) is not considered. otp_cardops.c:otp_pw_valid(): always set minauthtime to 0 cryptocard.c:cryptocard_twin2authtime(): return current time, not 0 Modified files: File: radiusd/src/modules/rlm_otp/otp_cardops.c; Revision: 1.40; Date: 2005/10/25 01:26:47; Author: fcusack; Lines: (+4 -4) File: radiusd/src/modules/rlm_otp/cardops/cryptocard.c; Revision: 1.21; Date: 2005/10/25 01:26:47; Author: fcusack; Lines: (+3 -6) ===================================================== Log entries ===================================================== Description: Clean up rad_vp2attr. This version is a LOT more readable than the previous code. Modified files: File: radiusd/src/lib/radius.c; Revision: 1.167; Date: 2005/10/24 19:54:51; Author: aland; Lines: (+101 -125) ------------------------------- Description: run all known cardops constructors if they didn't run (workaround for Cyclades ACS runtime linker deficiency) Modified files: File: radiusd/src/modules/rlm_otp/otp_cardops.c; Revision: 1.41; Date: 2005/10/25 05:29:29; Author: fcusack; Lines: (+23 -2) ===================================================== Summary of modified files ===================================================== File: radiusd/src/lib/radius.c Revisions: 1.167 Authors: aland (+101 -125) ------------------------------- File: radiusd/src/modules/rlm_otp/cardops/cryptocard.c Revisions: 1.21 Authors: fcusack (+3 -6) ------------------------------- File: radiusd/src/modules/rlm_otp/otp_cardops.c Revisions: 1.41, 1.40 Authors: fcusack (+23 -2), fcusack (+4 -4) -- Automatic cron job from /web/pages/us.freeradius.org/bin/new_makelog.pl