Coredump radiusd -X (debian 2.4 kernel) sql_trace=yes && mysql [freeradius 1.05]

Paul TBBle Hampson Paul.Hampson at
Tue Sep 27 18:49:10 CEST 2005

On Tue, Sep 27, 2005 at 12:54:29PM +0200, Nicolas Baradakis wrote:
> Bergman, Mark wrote:

>> I installed a clean debian (with a 2.4 kernel) and installed freeradius
>> 1.05.
>> I't worked with some minor changes to clients.conf. I could login to the
>> machine using NTRadPing.exe
>> Thereafter i installed mysql, created all the needed tables. Changed
>> sql.conf and tried to start radius.
>> A coredump was the result. Can anyone tell me what went wrong and how to
>> get it runnning?

> Try using the freeradius binary package from Debian.

>> I'm also still debugging myself. I guess the function lt_dlsym called in
>>  695         inst->module = (rlm_sql_module_t *) lt_dlsym(inst->handle,
>> inst->config->sql_driver);

> Looks like it's bug #98.

I doubt that. That bug looks to me like FreeRADIUS not being able to
load rlm_eap_tls due to no conf section, but then trying to load
rlm_eap_leap (the module after rlm_eap_gtc) and dying when it tries to
call on rlm_eap_tls. I'd actually suggest this bug is 'user
configuration' except that if building with disable-shared fixed it,
then it's not.

Paul "TBBle" Hampson, MCSE
8th year CompSci/Asian Studies student, ANU
The Boss, Bubblesworth Pty Ltd (ABN: 51 095 284 361)
Paul.Hampson at Pobox.Com

Of course Pacman didn't influence us as kids. If it did,
we'd be running around in darkened rooms, popping pills and
listening to repetitive music.
 -- Kristian Wilson, Nintendo, Inc, 1989

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <>

More information about the Freeradius-Devel mailing list