Coredump radiusd -X (debian 2.4 kernel) sql_trace=yes && mysql [freeradius 1.05]

Paul TBBle Hampson Paul.Hampson at
Tue Sep 27 18:56:11 CEST 2005

On Tue, Sep 27, 2005 at 09:40:23AM +0200, Bergman, Mark wrote:
> Hi,

> I installed a clean debian (with a 2.4 kernel) and installed freeradius
> 1.05.
> I't worked with some minor changes to clients.conf. I could login to the
> machine using NTRadPing.exe

> Thereafter i installed mysql, created all the needed tables. Changed
> sql.conf and tried to start radius.

> A coredump was the result. Can anyone tell me what went wrong and how to
> get it runnning?
> See the logfile for the log and some gdb output.

> I'm also still debugging myself. I guess the function lt_dlsym called in
>  695         inst->module = (rlm_sql_module_t *) lt_dlsym(inst->handle,
> inst->config->sql_driver);
> Expects none of the arguments to be NULL and apearantly one of the 2 is!

Do you have the freeradius-mysql package installed?

Check if you have /usr/lib/freeradius/ and check if
ldd-ing it shows no problems with (This
last one shouldn't be a problem, mysql-client would have pulled it in)

You haven't said which one was NULL, either.

Paul "TBBle" Hampson, MCSE
8th year CompSci/Asian Studies student, ANU
The Boss, Bubblesworth Pty Ltd (ABN: 51 095 284 361)
Paul.Hampson at Pobox.Com

Of course Pacman didn't influence us as kids. If it did,
we'd be running around in darkened rooms, popping pills and
listening to repetitive music.
 -- Kristian Wilson, Nintendo, Inc, 1989

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <>

More information about the Freeradius-Devel mailing list