broken --prefix=/ (summary)

Nicolas Baradakis nbk at
Wed Aug 16 20:18:45 CEST 2006

Stephen Gran wrote:

> No, wait - I think I see a problem.  If I run
> ./configure --prefix='/usr' --with-raddbdir=/etc/raddb
> make
> make install R=`pwd`foo
> I get everything working as normal (well, I get an error that it can't
> find /etc/raddb/radiusd.conf, but that's what I was looking for)
> If I then run
> ./configure --prefix='/usr' --with-raddbdir=/etc/freeradius
> make
> make install R=`pwd`foo
> Nothing gets rebuilt, and it still looks for radiusd.conf in the old
> location.  I am not sure what to do about this, besides making sure
> I run clean in between rebuilds.

Thanks for the report. I see indeed a bug when you don't run
"make distclean" between two builds with different configure
options. The file src/include/radpaths.h contains the pathnames
of the previous build.

The following patch should fix the problem:

Index: src/include/Makefile
RCS file: /source/radiusd/src/include/Makefile,v
retrieving revision 1.2
diff -u -r1.2 Makefile
--- src/include/Makefile        15 Jul 2003 12:34:51 -0000      1.2
+++ src/include/Makefile        16 Aug 2006 18:09:37 -0000
@@ -10,7 +10,7 @@
 all: radpaths.h
+radpaths.h: build-radpaths-h
        @/bin/sh ./build-radpaths-h
Nicolas Baradakis

More information about the Freeradius-Devel mailing list