broken --prefix=/ (summary)

Stephen Gran steve at
Wed Aug 16 19:07:13 CEST 2006

On Wed, Aug 16, 2006 at 06:46:39PM +0300, Peter Nixon said:
> On Thu 10 Aug 2006 20:51, Alan DeKok wrote:
> > Peter Nixon <listuser at> wrote:
> > > Does anyone know why "--prefix=3D/" not longer works as expected when fed
> > > to configure in the 1.1.x cvs branch?
> >
> >   Nope.  That makes me happy that I've been holding off on 1.1.3.
> >
> >   I'll take a look.
> OK. As this thread has continued on quite a bit, I am going to summarise it 
> for everyone.
> --prefix does appear to work as expected and for most people should be 
> specified as --prefix=/usr
> However, raddb does NOT end up in the expected location, and even 
> adding "--with-raddbdir=/etc/raddb" to configure (which in any case was 
> previously not necessary) does not make it end up where it should.

Odd, it does here.

No, wait - I think I see a problem.  If I run
./configure --prefix='/usr' --with-raddbdir=/etc/raddb
make install R=`pwd`foo

I get everything working as normal (well, I get an error that it can't
find /etc/raddb/radiusd.conf, but that's what I was looking for)

If I then run
./configure --prefix='/usr' --with-raddbdir=/etc/freeradius
make install R=`pwd`foo

Nothing gets rebuilt, and it still looks for radiusd.conf in the old
location.  I am not sure what to do about this, besides making sure
I run clean in between rebuilds.  I think that the right way would be
#define RADDBDIR '/etc/raddb' (and other configure arguments like this)
in acconfig.h, and then set make file targets accordingly.  That way
make will know to rebuild radiusd if this file changes.

I understand the problem of expansions with #define'ing these sorts of
things (you end up with ${prefix}/${argument} and so on), but I think I
may have an autoconf macro around that does a couple of expansions, so
that you should end up wioh a real path at the end, if people are
|  Stephen Gran                  | Time as he grows old teaches all        |
|  steve at             | things.   -- Aeschylus                  |
| |                                         |
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
URL: <>

More information about the Freeradius-Devel mailing list