building v.1.1.3(cvs) on different systems

Nicolas Baradakis nbk at
Mon Aug 21 15:04:15 CEST 2006

Markus Krause wrote:

> i just tested the building of todays cvs checkout of branch_1_1, here is
> what happend (maybe you want to know ;-)):

Thanks for the report, your tests are very useful.

> * debian sarge 3.1a:
>  building worked without problems, except some warnings at the end from
> "dh_shlibdeps -s: dpkg-shlibdeps: warning: could not find path for
>" (and others), but the installed version works.

Indeed. I've seen these warnings for years, but as you said it works
without problems.


> * mac os x 10.4.7:
>  running ./configure and then make leads to:
> /usr/bin/ld: multiple definitions of symbol _mainconfig
> .libs/radrelay.o definition of _mainconfig in section (__DATA,__common)
> .libs/mainconfig.o definition of _mainconfig in section (__DATA,__common)

It seems radrelay doesn't need to link with mainconfig.o anymore. Please
do a "cvs update" and try again with no configure option.

> then i tried "./configure --disable-shared" (i remembered something ...)
> and got until:
> /usr/bin/ld: Undefined symbols:
> _boot_DynaLoader

It looks like a problem with rlm_perl. This time please try to build
with "./configure --disable-shared --without-rlm-perl". Please also
post the output of the command "perl -MExtUtils::Embed -e ldopts".

Nicolas Baradakis

More information about the Freeradius-Devel mailing list