1.1.2: specifying installation directory (env R) causes install to fail

Kevin Bonner keb at pa.net
Thu Jun 1 23:58:17 CEST 2006

OS: CentOS 4
FR version: 1.1.2

I've tried to build the latest FR release and found the modules were being 
linked against the 1.1.0 version of libradius I had installed.  After 
removing all 1.1.0 binaries and libraries, I tried compiling again and am 
receiving the following errors.  I'm having some trouble determining where to 
fix this, so any patches/suggestions would be appreciated.  I can provide 
more output (or the full output) if it helps with debugging.

In the gcc line, if I add "-L/tmp/freeradius-buildroot/usr/local/lib" and run 
it by hand to build the module, everything works as expected.  Probably just 
a missing $(R) somewhere, but it's been a while since I've had to heavily 
dive into autoconf/make files.

Kevin Bonner

$ mkdir /tmp/freeradius-buildroot
$ ./configure && make && make R=/tmp/freeradius-buildroot install
gcc -shared  rlm_checkval.lo  -Wl,--rpath -Wl,/usr/local/lib  -L/usr/local/lib 
-lradius -lnsl -lresolv -lpthread   -Wl,-soname -Wl,rlm_checkval-1.1.2.so 
-o .libs/rlm_checkval-1.1.2.so
/usr/bin/ld: cannot find -lradius
collect2: ld returned 1 exit status
libtool: install: error: relink `rlm_checkval.la' with the above command 
before installing it
libtool: install: warning: remember to run `libtool --finish /usr/local/lib'
$ cd /tmp/freeradius-buildroot/usr/local/lib/
$ ls -1 libradius*
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 191 bytes
Desc: not available
URL: <http://lists.freeradius.org/pipermail/freeradius-devel/attachments/20060601/9fc76855/attachment.pgp>

More information about the Freeradius-Devel mailing list