RPM packaging

Nicolas Baradakis nbk at sitadelle.com
Mon Sep 11 15:10:04 CEST 2006

Sandworm wrote:

> I got the SPEC file from CVS and tried to build 1.1.3 with it. (As a
> SPEC file, if it was OK, it should have worked regardless of whether
> I was trying 1.1.3 or later). However, we fall into the same situation
> that started this whole discussion - that of "Installed (but unpackaged)
> file(s) found".

Thanks for the report. You have done many tests until now, and it was
very useful.

> This is because the files are present in the right spot (whether
> installed by the Makefile or by the %install section), but nothing
> has told RPM to package these in the %files section.
> The addition of one line, however, fixes this, shown below:
> [...]

No problem, I've updated the CVS head. Hopefully now rpmbuild will
work out of the box and do the right thing.

> If this one line is put into the CVS head redhat/freeradius.spec,
> this would be great.

I think this would be great if the Suse specfile could use the same
method, i.e. directly package the files installed by the Makefile.
If Peter agrees, I'll change suse/freeradius.spec too.

Nicolas Baradakis

More information about the Freeradius-Devel mailing list