RPM packaging

Peter Nixon listuser at peternixon.net
Tue Sep 12 12:21:20 CEST 2006

On Mon 11 Sep 2006 13:10, Nicolas Baradakis wrote:
> Sandworm wrote:
> > I got the SPEC file from CVS and tried to build 1.1.3 with it. (As a
> > SPEC file, if it was OK, it should have worked regardless of whether
> > I was trying 1.1.3 or later). However, we fall into the same situation
> > that started this whole discussion - that of "Installed (but unpackaged)
> > file(s) found".
> Thanks for the report. You have done many tests until now, and it was
> very useful.
> > This is because the files are present in the right spot (whether
> > installed by the Makefile or by the %install section), but nothing
> > has told RPM to package these in the %files section.
> >
> > The addition of one line, however, fixes this, shown below:
> >
> > [...]
> No problem, I've updated the CVS head. Hopefully now rpmbuild will
> work out of the box and do the right thing.
> > If this one line is put into the CVS head redhat/freeradius.spec,
> > this would be great.
> I think this would be great if the Suse specfile could use the same
> method, i.e. directly package the files installed by the Makefile.
> If Peter agrees, I'll change suse/freeradius.spec too.

Please don't.


Peter Nixon
PGP Key: http://www.peternixon.net/public.asc
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <http://lists.freeradius.org/pipermail/freeradius-devel/attachments/20060912/8e29d7ee/attachment.pgp>

More information about the Freeradius-Devel mailing list