Error: FATAL Failed to initialize semaphore: Function not implemented

Steven Simon simon.s at
Fri Aug 3 16:19:38 CEST 2007

There aren't any Apple changes to threading. I just tried running  
radiusd in daemon mode with the Apple version and got the same error.

When we run radiusd, it's through launchd, which serves the same  
purpose as xinetd on other platforms to keep the process running.

We run the process with args "-sf" to stop daemonization and run as a  
child of launchd.

To run radiusd this way, create a file named "/System/Library/ 
LaunchDaemons/org.freeradius.radiusd.plist" with the contents:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://">
<plist version="1.0">

Run "launchctl load /System/Library/LaunchDaemons/ 
org.freeradius.radiusd.plist" to start radiusd.

- Steve

On Aug 3, 2007, at 5:43 AM, Alan DeKok wrote:

> Arran Cudbard-Bell wrote:
>> "there's an issue to do with the way semaphores are implemented on  
>> OS X
>> (basically, you can't use "unnamed" ones -- there's a very old thread
>> about this in the freeradius-users list from 2004, with workarounds).
>> I'm guessing that there's something wrong in the "configure" for  
>> OS X,
>> meaning that it isn't using the right flavour of semaphore
>> initialisation, OR that 2.0 has a regression to the previous problem
>> that was fixed in 1.x"
>   Pretty much, but the relevant code wasn't changed in 2.0, either in
> configure or in src/main/threads.c.
>> Any chance someone could take a look at this ?
>> Be happy to provide any extra information required.
>   Apple just released their version of the code.  I'll take a look to
> see if there's anything special there.  It may also be useful for  
> me to
> have SSH access to a Mac box.
>   Alan DeKok.
> -
> List info/subscribe/unsubscribe? See 
> devel.html

More information about the Freeradius-Devel mailing list