Error: FATAL Failed to initialize semaphore: Function not implemented

Arran Cudbard-Bell A.Cudbard-Bell at
Fri Aug 3 17:29:52 CEST 2007

Steven Simon wrote:
> There aren't any Apple changes to threading. I just tried running  
> radiusd in daemon mode with the Apple version and got the same error.
> When we run radiusd, it's through launchd, which serves the same  
> purpose as xinetd on other platforms to keep the process running.
> We run the process with args "-sf" to stop daemonization and run as a  
> child of launchd.
> To run radiusd this way, create a file named "/System/Library/ 
> LaunchDaemons/org.freeradius.radiusd.plist" with the contents:
> <?xml version="1.0" encoding="UTF-8"?>
> <!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http:// 
> <plist version="1.0">
> <dict>
>          <key>Disabled</key>
>          <false/>
>          <key>Label</key>
>          <string>org.freeradius.radiusd</string>
>          <key>OnDemand</key>
>          <false/>
>          <key>Program</key>
>          <string>/usr/sbin/radiusd</string>
>          <key>ProgramArguments</key>
>          <array>
>                  <string>/usr/sbin/radiusd</string>
>                  <string>-sf</string>
>          </array>
>          <key>ServiceIPC</key>
>          <false/>
> </dict>
> </plist>
> Run "launchctl load /System/Library/LaunchDaemons/ 
> org.freeradius.radiusd.plist" to start radiusd.
> - Steve
> On Aug 3, 2007, at 5:43 AM, Alan DeKok wrote:
Thanks Steve,
Yes we already tried this :)

Unfortunately because we are using multi cored servers, theres going to 
be a big performance hit running it in single thread mode.

We will have to do this if the issue isn't resolved though *sigh*

This has only happened in the last month or so, I remember everything 
running fine before then.


More information about the Freeradius-Devel mailing list