Debian Dependencies - CVS Head

Humberto Diogenes humberto at
Sat Sep 1 05:24:04 CEST 2007

Hi, guys!

   Yesterday, I tried to compile the latest FreeRadius (cvs head) on  
Sarge and got this:

dpkg-buildpackage: source package is freeradius
dpkg-buildpackage: source version is 2.0.0-pre2
dpkg-buildpackage: source maintainer is Nicolas Baradakis  
<nbk at>
dpkg-buildpackage: host architecture is i386
dpkg-checkbuilddeps: Unmet build dependencies: debhelper (>= 5) dpkg- 
dev (>= 1.13.25)
dpkg-buildpackage: Build dependencies/conflicts unsatisfied; aborting.
dpkg-buildpackage: (Use -d flag to override.)

   I should note that 2.0pre0 worked fine, and trying with -d didn't  

   I thought: OK, tomorrow I install on a new machine. Got one with  
Ubuntu Server LTS, and then... got the same error. This time the  
error was only with dpkg-dev (Ubuntu comes with 1.13.11), but anyway,  
does it really need those versions? What do I have to use to compile  
it without errors?

P.S.: I ended up commenting the dependency and it (seems to have)  

Humberto Diógenes

More information about the Freeradius-Devel mailing list