Can someone confirm that glibc 2.4 is now a requirement?

Matthew Schumacher matt.s at
Thu Sep 11 17:10:51 CEST 2008


I have an old machine that is still in use running glibc 2.3 and can't
get freeradius 2.1.0 or the latest git to compile because of this error:

gcc -o .libs/radeapclient .libs/radeapclient.o
-lnsl -lresolv -lpthread -lreadline -ltermcap -lssl -lcrypto
undefined reference to `___tls_get_addr'

My reading suggests that I need glibc 2.4 to have tls built in.  Can
someone confirm that is the case or is there some way to compile without it?

I should also mention that 2.1.0 fails to compile on my newer hosts, but
the latest git fixes that so 2.1.1 will fix my compilation issues on my
newer machines.


More information about the Freeradius-Devel mailing list