Can someone confirm that glibc 2.4 is now a requirement?

Alan DeKok aland at
Thu Sep 11 20:38:18 CEST 2008

Matthew Schumacher wrote:
> I have an old machine that is still in use running glibc 2.3 and can't
> get freeradius 2.1.0 or the latest git to compile because of this error:
> /mnt/data/software/linux/slackware/10.1/packages/daemons/freeradius-server/radiusd/src/lib/.libs/
> undefined reference to `___tls_get_addr'

  <sigh>  So the "configure" script discovers that thread-local storage
is available... but it's not available at run time.

> My reading suggests that I need glibc 2.4 to have tls built in.  Can
> someone confirm that is the case or is there some way to compile without it?

  I'll see if I can add a configure option to disable thread-local storage.

> I should also mention that 2.1.0 fails to compile on my newer hosts, but
> the latest git fixes that so 2.1.1 will fix my compilation issues on my
> newer machines.

  Yeah... that's the <ltdl.h> thing.

  Alan DeKok.

More information about the Freeradius-Devel mailing list