Make Failing during installation of Radius server version 3.0.12

Javed jaakhtar at
Tue Jan 17 13:49:57 CET 2017

Hello All,

I solved the previous error related to permission denied and it was the file install-sh was not made executable and then later in order to complete make I solved some issues which made it stopped. Now I am struck in this 

including configuration file /usr/local/etc/raddb/sites-enabled/default
including configuration file /usr/local/etc/raddb/sites-enabled/inner-tunnel
main {
 security {
        allow_core_dumps = no
        name = "radiusd"
        prefix = "/usr/local"
        localstatedir = "/var"
        logdir = "/var/log"
        run_dir = "/var/run/radiusd"
/usr/local/etc/raddb/radiusd.conf[380]: Configuration item "allow_core_dumps" is deprecated
radiusd: Error: Failed to parse user/group information.

Can anybody suggest if this was logged previously?


Javed Akhtar
Technical Lead
jaakhtar at
Cisco Systems, Inc.


Think before you print.
This email may contain confidential and privileged material for the sole use of the intended recipient. Any review, use, distribution or disclosure by others is strictly prohibited. If you are not the intended recipient (or authorized to receive for the recipient), please contact the sender by reply email and delete all copies of this message.
Please click here for Company Registration Information.

-----Original Message-----
From: Freeradius-Users [ at] On Behalf Of Brian Candler
Sent: 17 January 2017 16:57
To: FreeRadius users mailing list <freeradius-users at>
Subject: Re: Make Failing during installation of Radius server version 3.0.12

On 17/01/2017 06:36, Nathan Ward wrote:
>> gmake: execvp: 
>> /data/home/jaakhtar/freeradius-server-3.0.12/install-sh: Permission 
>> denied
>> gmake: *** [raddb/sites-enabled] Error 127
> The error is quite clear, it says “permission denied”. Some basic knowledge of unix systems really is required if you are building things from source.
> You are trying to install something to your system, run it as root or another user that has permissions to write to the directory you have directed it to install to.

Or it could be that the execute bit (+x) is not present on install-sh

However it is present on my local git checkout:

$ ls -l install-sh
-rwxr-xr-x  1 brian  staff  5615  6 Oct 19:11 install-sh

And I've checked the published tarball at

$ tar -tvzf freeradius-server-3.0.12.tar.gz | grep install-sh
-rwxrwxr-x  0 root   root     5615 29 Sep 16:19 

The OP needs to check how their own source tree was unpacked.
List info/subscribe/unsubscribe? See

More information about the Freeradius-Devel mailing list