Alan DeKok aland at
Tue Jan 8 19:07:53 CET 2019

On Jan 8, 2019, at 12:44 PM, Onur GURSOY <onurgursoygyte at> wrote:
> first, i tried 2.0.x branch because i noticed this:

  I don't think that page has been updated for 10 years...

> so i tried compile freeradius which is version from 2.0.0 to 2.1.9 on cygwin
> i take a single error. its already in  first messages.
> I solved problem by the disabling static compiling from
> configuration.Because i think this problem is relevant crypto ssl  and
> static binding zlib (NOTE: this is real solution ? i dont know yet)

  If it works...

> After succesfuly compiling, i started the radiusd.exe but there is no
> output on cosole or output of ps -ef.
> here is the relevant log (radius.log):
>> $ cat /usr/local/freeradius/var/log/radius/radius.log
>> Tue Jan  8 20:24:06 2019 : Error:
>> /usr/local/freeradius/etc/raddb/radiusd.conf[1560]: Failed to link to
>> module 'rlm_exec': The specified module could not be found.
>> Tue Jan  8 20:24:06 2019 : Error: Errors initializing modules

  Start it in debug mode.  That will be better.

  And I'm not sure that static linking works, TBH.  It's just terrible.

> i attached radiusd,conf file my configuration file.

  Please don't do that.  We don't need to see it.  We already know what's in the config files.

> Because freeradius 3.0.x bracnh doesnt compile on cygwin
> The output is not this computer, i will send soon, because i changed many
> things and i installed many library such as libtalloc for compiling.


  Alan DeKok.

More information about the Freeradius-Devel mailing list