[4.0.x] build fails (module imap) with libcurl 7.29.0

Alan DeKok aland at deployingradius.com
Mon Jun 29 12:54:40 CEST 2020

On Jun 28, 2020, at 1:20 PM, Chaigneau, Nicolas via Freeradius-Devel <freeradius-devel at lists.freeradius.org> wrote:
> It's perfectly fine to require a recent version of libcurl.
> Just a minor inconsistency remains in the configure output... the minimum version shown in the WARNING is incorrect (should be 7.45.0, not 7.19.2):
> checking for the version of libcurl... 7.29.0
> checking for libcurl >= version 7.45.0... no
> configure: WARNING: silently not building libfreeradius-curl.
> configure: WARNING: FAILURE: libfreeradius-curl requires:  libcurl >= 7.19.2.
> configure: creating ./config.status

  I don't see that here.  There's no "7.19.2" string in the source.  Maybe just "git pull" again?

  Alan DeKok.

More information about the Freeradius-Devel mailing list