erros building suse rpm

Markus Krause krause at
Sat Oct 22 20:30:27 CEST 2005

hi list,

i tried to build an rpm-package for suse using freeradius-1.0.5 on both sles 9
and suse 10.0-oss with same results.

unfortunately it did not go smoothly, here is what i did and what happend:
1) i edited freeradius.spec:
 - correcting the version info in the second line from 1.0.2 to 1.0.5
 - changing versino from 1.0.4 to 1.0.5 in the section with name, licence,
group, etc.
 - in BuildRequires i removed "postgresql", "libnscd", "libzio". the reason for
removing the last two was that i could not find them in sles9. does anyone know
in which package they should be? but i think that the building problems do not
depend on these.

2) at the end of "CFLAGS" in the section "%build" i added
"--with-experimental-modules" (i need the sqlcounter module)

3) then i run "rpmbuild -ba freeradius.spec". at the end (i assume after
compiling, on bundling the package) i get:
Checking for unpackaged file(s): /usr/lib/rpm/check-files
error: Installed (but unpackaged) file(s) found:

RPM build errors:
    Installed (but unpackaged) file(s) found:
as i do not use/need rlm_perl i just uncommented the line containing this
information (after "install-scripts:" in src/modules/rlm_perl/ the
building is succesfull, and the installed package works correctly.
what would the correct action and not a work-around?


Markus Krause                           email: krause at
Computing Center                        Tel.: 089 - 89 40 85 99
Group Lottspeich / Proteomics           Fax.: 089 - 89 40 85 98

     This message was sent using
If you encounter any problems please report to rz-linux at

More information about the Freeradius-Users mailing list