Cannot compile and run on Mac OS X 10.4.7

Michael Check michaelr.check at
Wed Aug 23 14:40:00 CEST 2006

On 8/22/06, Stephen Gran <steve at> wrote:
> Did rlm_exec actually get built and installed?

Yes, as far as I can tell, it was in /usr/local/lib

> Can you try 1.1.3 (in CVS right now, due Any Day Now) and see if it does
> better?  There was a substantial build system rework involved.

I tried it.  ./configure, make, make install with 1.1.3 gets through
the process with the same (non) issues as 1.1.2.

Running sudo radiusd -X

MAI-CHI-MINI:/usr/local/src/freeradius-1.1.3 mcheck$ sudo
/usr/local/sbin/radiusd -X
Starting - reading configuration files ...
reread_config:  reading radiusd.conf
Config:   including file: /usr/local/etc/raddb/proxy.conf
Config:   including file: /usr/local/etc/raddb/clients.conf
Config:   including file: /usr/local/etc/raddb/snmp.conf
Config:   including file: /usr/local/etc/raddb/eap.conf
Config:   including file: /usr/local/etc/raddb/sql.conf
 main: prefix = "/usr/local"
 main: localstatedir = "/usr/local/var"
 main: logdir = "/usr/local/var/log/radius"
 main: libdir = "/usr/local/lib"
 main: radacctdir = "/usr/local/var/log/radius/radacct"
 main: hostname_lookups = no
 main: max_request_time = 30
 main: cleanup_delay = 5
 main: max_requests = 1024
 main: delete_blocked_requests = 0
 main: port = 0
 main: allow_core_dumps = no
 main: log_stripped_names = no
 main: log_file = "/usr/local/var/log/radius/radius.log"
 main: log_auth = no
 main: log_auth_badpass = no
 main: log_auth_goodpass = no
 main: pidfile = "/usr/local/var/run/radiusd/"
 main: user = "(null)"
 main: group = "(null)"
 main: usercollide = no
 main: lower_user = "no"
 main: lower_pass = "no"
 main: nospace_user = "no"
 main: nospace_pass = "no"
 main: checkrad = "/usr/local/sbin/checkrad"
 main: proxy_requests = yes
 proxy: retry_delay = 5
 proxy: retry_count = 3
 proxy: synchronous = no
 proxy: default_fallback = yes
 proxy: dead_time = 120
 proxy: post_proxy_authorize = no
 proxy: wake_all_if_all_dead = no
 security: max_attributes = 200
 security: reject_delay = 1
 security: status_server = no
 main: debug_level = 0
read_config_files:  reading dictionary
read_config_files:  reading naslist
Using deprecated naslist file.  Support for this will go away soon.
read_config_files:  reading clients
read_config_files:  reading realms
radiusd:  entering modules setup
Module: Library search path is /usr/local/lib
radiusd.conf[1565] Failed to link to module 'rlm_exec':
dlopen(/usr/local/lib/, 9): Symbol not found:
_debug_flag   Referenced from: /usr/local/lib/
Expected in: flat namespace

rlm_exec is built, here is the directory snip from /usr/local/lib

lrwxr-xr-x     1 root  wheel       11 Aug 23 07:18
-rwxr-xr-x     1 root  wheel    21204 Aug 23 07:18
-rw-r--r--     1 root  wheel    14488 Aug 23 07:18 rlm_exec.a
-rwxr-xr-x     1 root  wheel      855 Aug 23 07:18
lrwxr-xr-x     1 root  wheel       17 Aug 23 07:18 ->

Also tried

export LD_PRELOAD=/usr/local/lib/
sudo radiusd -X

And got the same result.

Is there any other part of the compile that would be useful to see?

Thanks in advance,

Michael Check

More information about the Freeradius-Users mailing list