Cannot compile and run on Mac OS X 10.4.7

Stephen Gran steve at
Wed Aug 23 18:29:03 CEST 2006

On Wed, Aug 23, 2006 at 07:40:00AM -0500, Michael Check said:
> On 8/22/06, Stephen Gran <steve at> wrote:
> >Can you try 1.1.3 (in CVS right now, due Any Day Now) and see if it does
> >better?  There was a substantial build system rework involved.
> I tried it.  ./configure, make, make install with 1.1.3 gets through
> the process with the same (non) issues as 1.1.2.


> Module: Library search path is /usr/local/lib
> radiusd.conf[1565] Failed to link to module 'rlm_exec':
> dlopen(/usr/local/lib/, 9): Symbol not found:
> _debug_flag   Referenced from: /usr/local/lib/
> Expected in: flat namespace

This is a (apparently OS X specific) linker issue, it looks like.

debug_flag is declared as an extern int in radiusd.h and included in
rlm_exec.  ldd shows me that the symbol is present and undefined in the
module on linux as well, but the linker magic hooks it all together at
run time here.

I _think_ that it blows up in rlm_exec because it's the first module
that uses a symbol from the radiusd binary (as opposed to a library).
I also think this has something to do with the mystery that is OS X's
linker namespaces.  Beyond that, I'm starting to flounder.  I have no
Mac machine handy to test these assumptions on (and I'm not even sure
how I would test the second one), so I can't really say much more, sorry.

I see several references on line about special issues with OS X and
dlopen'ed plugins and modules, and I assume this is the problem area.
I'm guessing that your way forward is to start hacking on libltdl to
make it work with OS X, but that looks, er, painful.

If you don't actually need the modules that cause problems, you can
comment the references out and see if that gets you by.

Good luck, and sorry, but without something to test on, I'm out of
|  Stephen Gran                  | Better tried by twelve than carried by  |
|  steve at             | six.   -- Jeff Cooper                   |
| |                                         |
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
URL: <>

More information about the Freeradius-Users mailing list