FreeRadius and MySQL boot problem

Diniz Da Rocha dinizd at
Tue Feb 28 06:00:15 CET 2006

I also had that impression so I did a sleep for 30 secs but still no luck, I
was wondering if it has something to do with the user who runs at startup if
its not root??? but havent any info on this yet... what os are you
running your FreeRadius on???

On 2/28/06, Dennis Skinner <dskinner at> wrote:
> Diniz Da Rocha wrote:
> > The MySQL server is on another server with ip "myip" I initially thought
> > it was a firewall block but even with no firewall I get this error. But
> > once the server has started and I run "service radiusd restart" from a
> > terminal the connect to the MySQL server works fine and has no problems.
> > I even tried running the service from rc.local but it still fails did
> > anyone have this problem??? is anyone running the MySQL server on
> > another machine???? Is there a fix for this???
> Our SQL server is on another machine and works fine on reboots.  It
> looks like your networking service may not be completely up and
> functional before radius starts.  Add a sleep for 10 or 20sec in
> rc.local before FR starts and see what happens.
> --
> Dennis Skinner
> Systems Administrator
> BlueFrog Internet
> -
> List info/subscribe/unsubscribe? See
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Freeradius-Users mailing list