FreeRadius installation problem.

Ramm-Ericson, Johannes Johannes.Ramm-Ericson at
Wed Nov 1 08:55:27 CET 2006

Chad Best wrote:
> Date: Tue, 31 Oct 2006 09:45:09 -0800 (PST)
> From: Chad Best <chadabst-1 at>
> Subject: FreeRadius installation problem.
> To: freeradius-users at
> Message-ID: <20061031174509.18334.qmail at>
> Content-Type: text/plain; charset="iso-8859-1"
> When I run ./confiugre, make and make install, "radiusd" does not 
> install.  I have checked the/usr/local/bin and /usr/local/sbin and it 
> is not there.  Yes, I did make sure that I was showing hidden files 
> when I search for it.  I also did a search for radiusd and it does not

> show up anywhere.  Therefore, when I try to run radiusd by typing
> "radiusd -X", it says command not found.
> I am running Ubuntu Linux and trying to install 
> Freeradius-1.0.0(behind the times, I know).  I am a total newbie to 
> Freeradius altogether, so please be patient!  I have already tried to 
> reinstall, but that didn't work.  Any help would greatly be

Hi Chad!

Is there any particular reason that you are compiling from source (and
using a very old version of freeradis aswell)? If there is no absolute
requirement for you to compile from source I'd suggest using the
freeradius package in the ubuntu repository. That should get you started
with freeradius. YMMV but once you've had a chance to play around with
freeradius and maybe want to start using it in a more demanding fashion
- then I'd go with compiling it myself. Install it using the following

sudo apt-get install freeradius

In Ubuntu 6.10 (Edgy) you'll be installing freeradius 1.1.3 (the latest
stable version). I think Ubuntu 6.06 (Dapper) carries freeradius 1.1.2 -
but I'm not sure.


More information about the Freeradius-Users mailing list