NTLM_Auth will not work from within FreeRadius

Neal Bullins nbullins at gborocollege.edu
Tue Nov 21 04:40:01 CET 2006

Hey All,

I am trying to configure FreeRadius (on Debian) to authenticate against 
Samba. Running NTLM_Auth from the command line results in a valid login. 
However FreeRADIUS call to ntlm_auth results in a Logon failure.

 From the command line I run:

/usr/bin/ntlm_auth --request-nt-key --domain=MyDom --username=radtest 
(MyDom is not the actual Domain but still works when I use it in place 
of the actual domain???)

And then I enter the correct password and the result is “NT_STATUS_OK: 
Success (0x0)”.

The debug output from freeradius is:

Exec-Program: /usr/bin/ntlm_auth --request-nt-key --domain=MyDom 
--username=radtest --challenge=3bdc9461e268b957 

Exec-Program output: Logon failure (0xc000006d)

I would assume that there is some sort of problem with the creation of 
the challenge/response but that is difficult to test. I have tried two 
different usernames/passwords and both combinations result in the same 
error. Any suggestions?


More information about the Freeradius-Users mailing list