glibc double free or corruption still happening

Jacob Jarick mem.namefix at
Fri Apr 13 18:03:22 CEST 2007

have u tried this which was suggested by Nicolas Baradakis <nbk at> 	

You could try to use the libltdl from Fedora instead of the one
from the FreeRADIUS sources.

$ ./configure --with-system-libtool

On 4/13/07, Alan DeKok <aland at> wrote:
> Roberto Greiner wrote:
> > I've installed FreeRadius 1.1.6 to my Debian Etch box, trying to solve
> > the 'glibc double free or corruption', but the error is still happening.
>   I'de love to know where it's coming from.
>   I ran it on my system, and under valgrind, and say nothing.
> > To make sure that no old library was causing the problem, I searched for
> > any file and folder which could be from the old freeradius (using locate
> > *radiu* and updatedb, it until no file was to be found). Then I
> > recompiled everything and reinstalled. The problem persisted. Could I
> > have missed some library with the locate I used? Is there a better way
> > to uninstall everything for the upgrade? Any other Ideas?
> $ valgrind --tool=memcheck --leak-check=full radiusd -X
>   It might get you more information.
>   Alan DeKok.
> --
>       - The web site of the book
> - The blog
> -
> List info/subscribe/unsubscribe? See

More information about the Freeradius-Users mailing list