SEVERE! radiusd 2.0 and 1.1.4 dying! Segmentation fault

Phil Mayers p.mayers at
Sun Jan 28 00:07:49 CET 2007

Guilherme Franco wrote:
> Hi,
> Freeradius 2.0 alpha was working correctly since November 1st.
> Then, this month, suddenly the server started to die, complaining of
> "Info: rlm_sql (sql): There are no DB handles to use! skipped 0, tried
> to connect 0".

This normally means your database is slow. Clean out old accounting 
records (maybe move them to another table) and execute a "vacuum analyze".

> The server runs threaded with max_servers = 32 and num_sql_socks = 32
> (there are 5 reqs per seconds, no more than that).
> Ok so I've tried to run it single threaded (-X), but then, it's slow
> and it missess some access requests, due to processing the accounting.

...indicating a high load, supporting the hypothesis.

> I've uninstalled it and installed 1.1.4, but the same occurs!
> Restarting radiusd when it fails gives another 15 minutes before it dies 
> again.
> Also, disabling accounting helps prolong the server lifetime.

Probably because it reduces the load, again supporting the hypothesis.

However - you also say it is segfaulting? Which I would not expect.

I don't really understand the format of the crash dump - can you supply 
one from "gdb" as documented in doc/bugs?

More information about the Freeradius-Users mailing list