Building FreeRadius

Abdelmonam Kouka abdelmonam.kouka at
Thu Dec 11 10:13:45 CET 2008


Yeh, I build the 2.1.3 version without problem and without installing
libtool!!! it was great to see that :)

but after running it, I tried to connect as test user but it was rejected!
is this normal, what I did is:
I run:
root at kouka-desktop:/home/kouka# export LD_LIBRARY_PATH=/usr/local/lib
root at kouka-desktop:/home/kouka# radiusd -X

then I got many lines then:
Listening on authentication address * port 1812
Listening on accounting address * port 1813
Listening on proxy address * port 1814
Ready to process requests.

so via another terminal I run (also as root, because with simple user it
said to me you are not allowed to access a config file under /etc/....):
root at kouka-desktop:/home/kouka# radtest test test localhost 0 testing123

I got in the client terminal this result:
Sending Access-Request of id 210 to port 1812
    User-Name = "test"
    User-Password = "test"
    NAS-IP-Address =
    NAS-Port = 0
rad_recv: Access-Reject packet from host port 1812, id=210,

and in the server terminal this one:
rad_recv: Access-Request packet from host port 45738, id=210,
    User-Name = "test"
    User-Password = "test"
    NAS-IP-Address =
    NAS-Port = 0
+- entering group authorize {...}
++[preprocess] returns ok
++[chap] returns noop
++[mschap] returns noop
[suffix] No '@' in User-Name = "test", looking up realm NULL
[suffix] No such realm "NULL"
++[suffix] returns noop
[eap] No EAP-Message, not doing EAP
++[eap] returns noop
++[unix] returns notfound
++[files] returns noop
++[expiration] returns noop
++[logintime] returns noop
[pap] WARNING! No "known good" password found for the user.  Authentication
may fail because of this.
++[pap] returns noop
No authenticate method (Auth-Type) configuration found for the request:
Rejecting the user
Failed to authenticate the user.
Using Post-Auth-Type Reject
+- entering group REJECT {...}
[attr_filter.access_reject]     expand: %{User-Name} -> test
 attr_filter: Matched entry DEFAULT at line 11
++[attr_filter.access_reject] returns updated
Delaying reject of request 0 for 1 seconds
Going to the next request
Waking up in 0.9 seconds.
Sending delayed reject for request 0
Sending Access-Reject of id 210 to port 45738
Waking up in 4.9 seconds.
Cleaning up request 0 ID 210 with timestamp +322
Ready to process requests.

Is that normal? how can I try that all run well?

Best regards.

2008/12/10 Alan DeKok <aland at>

> Abdelmonam Kouka wrote:
> > I am new on FreeRadius, I tried to build it from sources on ubuntu 8.04,
> > when I run ./configure all is OK, but when I run make I have got this
> error:
> >
> /home/kouka/Desktop/freeradius-server-2.1.2/src/freeradius-devel/modpriv.h:9:18:
>   Delete 2.1.2, and install 2.1.3.  See for
> comments.
>  Alan DeKok.
> -
> List info/subscribe/unsubscribe? See

عبد المنعم كوكة
Abdelmonam Kouka
Software Engineer
GNU/Linux user #450141
GPG Fingerprint: EC21 1E4E 5B0C E4E7 0D64  3305 0D62 75C9 2C15 16E0
"Some people see things as they are and say why.
I dream things that never were and say why not?"
                          [George Bernard Shaw]
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Freeradius-Users mailing list