Building FreeRadius

tnt at tnt at
Thu Dec 11 11:04:43 CET 2008

>I run:
>root at kouka-desktop:/home/kouka# export LD_LIBRARY_PATH=/usr/local/lib
>root at kouka-desktop:/home/kouka# radiusd -X
>then I got many lines then:
>Listening on authentication address * port 1812
>Listening on accounting address * port 1813
>Listening on proxy address * port 1814
>Ready to process requests.
>so via another terminal I run (also as root, because with simple user it
>said to me you are not allowed to access a config file under /etc/....):
>root at kouka-desktop:/home/kouka# radtest test test localhost 0 testing123
>I got in the client terminal this result:
>Sending Access-Request of id 210 to port 1812
>    User-Name = "test"
>    User-Password = "test"
>    NAS-IP-Address =
>    NAS-Port = 0
>rad_recv: Access-Reject packet from host port 1812, id=210,
>and in the server terminal this one:
>rad_recv: Access-Request packet from host port 45738, id=210,
>    User-Name = "test"
>    User-Password = "test"
>    NAS-IP-Address =
>    NAS-Port = 0
>+- entering group authorize {...}
>++[preprocess] returns ok
>++[chap] returns noop
>++[mschap] returns noop
>[suffix] No '@' in User-Name = "test", looking up realm NULL
>[suffix] No such realm "NULL"
>++[suffix] returns noop
>[eap] No EAP-Message, not doing EAP
>++[eap] returns noop
>++[unix] returns notfound
>++[files] returns noop
>++[expiration] returns noop
>++[logintime] returns noop
>[pap] WARNING! No "known good" password found for the user.  Authentication
>may fail because of this.
>++[pap] returns noop
>No authenticate method (Auth-Type) configuration found for the request:
>Rejecting the user
>Failed to authenticate the user.
>Using Post-Auth-Type Reject
>+- entering group REJECT {...}
>[attr_filter.access_reject]     expand: %{User-Name} -> test
> attr_filter: Matched entry DEFAULT at line 11
>++[attr_filter.access_reject] returns updated
>Delaying reject of request 0 for 1 seconds
>Going to the next request
>Waking up in 0.9 seconds.
>Sending delayed reject for request 0
>Sending Access-Reject of id 210 to port 45738
>Waking up in 4.9 seconds.
>Cleaning up request 0 ID 210 with timestamp +322
>Ready to process requests.

Where did you put that users password? It's not in users file.

Ivan Kalik
Kalik Informatika ISP

More information about the Freeradius-Users mailing list