Postgress SQL connections

Alan DeKok aland at
Sun Dec 14 18:58:04 CET 2008

Massimiliano Tarquini wrote:
> We have a full installation on freeradius 2.1.1 using postgreSql 8.1 running
> onto 2 different machines.
> The auth work fine 8we have tested it for two days with a killer script that
> tests in continuously) but if the proxy

  What proxy?  You haven't explained how you have the network set up.

> stops sending auth requests for a
> few minutes (sometimes 15, sometimes 40), at the first request freeradius
> start malefunctioning.
> Following the log content
> ----------------------------------------------------------------------------
> --------------------------------
> Sat Dec 13 16:19:38 2008 : Error: Discarding duplicate request from client
> Sat Dec 13 16:20:01 2008 : Error: WARNING: Unresponsive child for request
> 11657, in module sql component authorize

  That usually means that the database has blocked the server.  The
server is calling the DB client API to get data, and the API isn't

> Sat Dec 13 16:20:43 2008 : Info: rlm_sql (sql): There are no DB handles to
> use! skipped 0, tried to connect 0

  This happens when all of the DB connections are blocked.

> Which is really strange is that the connections to the database are up and
> the database works fine.

  The connections *exist*, but the server is telling you that they are
not working.

  If the databse is working fine, then the problem is the DB client API.

> After some retry the radius crash.

  See doc/bugs for instructions on what to do when this happens.

> We tried to schedule a -HUP signal every 5 minutes, but it has non effect.

  The DB client API will likely re-try on interrupt signals.

  Alan DeKok.

More information about the Freeradius-Users mailing list