2.1.3 and Solaris 9 compile errors

Greg Fuller gfuller at oswego.edu
Tue Dec 23 21:33:04 CET 2008

I'm trying to get freeradius v2.1.3 to compile on a Solaris 9 box.  I
have openssl installed in /usr/local/ssl/openssl and have pointed the
includes and libraries at that directory.  I still get compile errors
during install.

Perl is v5.6.1
OpenSSL is v0.9.6e

./configure runs fine without any errors, but when I run a make/gmake on
it, I get the following errors:

ld: fatal: relocations remain against allocatable but non-writable
collect2: ld returned 1 exit status
gmake[6]: *** [rlm_perl.la] Error 1
gmake[6]: Leaving directory
gmake[5]: *** [common] Error 2
gmake[5]: Leaving directory
gmake[4]: *** [all] Error 2
gmake[4]: Leaving directory
gmake[3]: *** [common] Error 2
gmake[3]: Leaving directory `/usr/local/src/freeradius-server-2.1.3/src'
gmake[2]: *** [all] Error 2
gmake[2]: Leaving directory `/usr/local/src/freeradius-server-2.1.3/src'
gmake[1]: *** [common] Error 2
gmake[1]: Leaving directory `/usr/local/src/freeradius-server-2.1.3'
gmake: *** [all] Error 2

I'm looking for JUST the VMPS functionality of freeradius.  Anyway to
try disabling all the other functionality and just compile the VMPS
portion of freeradius?  I can't seem to find a list of all the options
to disable with the --disabl-"FEATURE" option from ./configure.  


More information about the Freeradius-Users mailing list