2.1.3 and Solaris 9 compile errors

Alan DeKok aland at deployingradius.com
Wed Dec 24 11:21:17 CET 2008

Greg Fuller wrote:
> I'm trying to get freeradius v2.1.3 to compile on a Solaris 9 box.  I
> have openssl installed in /usr/local/ssl/openssl and have pointed the
> includes and libraries at that directory.  I still get compile errors
> during install.
> Perl is v5.6.1
> OpenSSL is v0.9.6e
> ./configure runs fine without any errors, but when I run a make/gmake on
> it, I get the following errors:
> `/usr/local/src/freeradius-server-2.1.3/src/modules/rlm_perl'

$ cd /usr/local/src/freeradius-server-2.1.3/
$ rm -rf src/modules/rlm_perl

> I'm looking for JUST the VMPS functionality of freeradius.

  If you don't want the Perl module, just delete it.  It causes problems
on a LOT of platforms.

>  Anyway to
> try disabling all the other functionality and just compile the VMPS
> portion of freeradius?  I can't seem to find a list of all the options
> to disable with the --disabl-"FEATURE" option from ./configure.  

  FreeRADIUS is still mostly a RADIUS server.  So most of the
functionality of RADIUS is built in, and can't be removed.

  Most of the modules *don't* implement RADIUS, however.  So they're all
built as part of the VMPS effort.

  Alan DeKok.

More information about the Freeradius-Users mailing list