build error on Solaris (undefined symbol)

Alan DeKok aland at
Mon Jun 15 14:11:33 CEST 2009

Ihsan Dogan wrote:
> I'm trying to build FreeRADIUS on Solaris (versions 9 and 10) and I'm
> getting this error:
> Undefined                       first referenced
>  symbol                             in file
> lt__PROGRAM__LTX_preloaded_symbols  .libs/modules.o

  I have no idea how to fix that.  It builds for me on Solaris.

  Random people seem to be running into this on various platforms, and I
don't know why.  It's definitely a libtool / libtldl issue, but that's
about all I can say.

> ld: fatal: Symbol referencing errors. No output written to .libs/radiusd
> gmake[6]: *** [radiusd] Error 1
> gmake[6]: Leaving directory
> `/home/ihsan/gar/csw/mgar/pkg/freeradius/trunk/work/build-isa-sparcv8/freeradius-server-2.1.6/src/main'
> -----------------------------------------------------------------
> Configure runs fine. I've tried to build FreeRADIUS with Sun Studio 12
> and GCC 4.3.3 and both show the same error.

  Are you disabling the ltdl install?

  What configure options are you using?

  Alan DeKok.

More information about the Freeradius-Users mailing list