build error on Solaris (undefined symbol)

Ihsan Dogan ihsan at
Mon Jun 15 15:07:53 CEST 2009

Hello Alan,

Alan DeKok wrote:

Thank you for the very quick reply.

>> I'm trying to build FreeRADIUS on Solaris (versions 9 and 10) and I'm
>> getting this error:
>> Undefined                       first referenced
>>  symbol                             in file
>> lt__PROGRAM__LTX_preloaded_symbols  .libs/modules.o
>   I have no idea how to fix that.  It builds for me on Solaris.

Have you been using as well the most recent version 2.2.6a of libtool?

>> Configure runs fine. I've tried to build FreeRADIUS with Sun Studio 12
>> and GCC 4.3.3 and both show the same error.
>   Are you disabling the ltdl install?


>   What configure options are you using?

./configure --prefix=/opt/csw --exec_prefix=/opt/csw
--bindir=/opt/csw/bin --sbindir=/opt/csw/sbin
--libexecdir=/opt/csw/libexec --datadir=/opt/csw/share
--sysconfdir=/opt/csw/etc --sharedstatedir=/opt/csw/share
--localstatedir=/opt/csw/var --libdir=/opt/csw/lib
--infodir=/opt/csw/share/info --includedir=/opt/csw/include

Nothing special so far.


ihsan at

More information about the Freeradius-Users mailing list