need help for adding VSA dictionary in Freeradius 2.1.6

Salim Engin salim.engin at
Thu Sep 10 21:12:31 CEST 2009


I have problem in adding new VSA dictionary file into Freeradius 2.1.6.
Below you can find the steps I performed;

- create  the file named *dictionary.alcatel.esam* with the following
content in */usr/local/share/freeradius/* folder;


VENDOR          Alcatel-ESAM    637

ATTRIBUTE       A-ESAM-VRF-Name           0x0700        string
ATTRIBUTE       A-ESAM-Vlan-Id            0x0701        integer
ATTRIBUTE       A-ESAM-QOS-Profile-Name   0x0702        string
ATTRIBUTE       A-ESAM-QOS-Params         0x0703        string
ATTRIBUTE       A-ESAM-Termination-Cause  0x0704        integer


- add the line below into */usr/local/share/freeradius/dictionary* file;

$INCLUDE dictionary.netscreen
$INCLUDE dictionary.networkphysics
$INCLUDE dictionary.nexans
$INCLUDE dictionary.ntua
*$INCLUDE dictionary.alcatel.esam*

- start radiusd with debugging option.

I get the following error message (radiusd -X ) ;

*including dictionary file /usr/local/etc/raddb/dictionary
Errors reading dictionary: dict_init:
/usr/local/share/freeradius/dictionary.alcatel.esam[9]: dict_init:
/usr/local/share/freeradius/dictionary.alcatel.esam[9]: *

According to my analysis, freeradius does not like the hex values in the VSA
dictionary file i.e : 0x0700 . So I tried to make it decimal which is 1792
but still getting the same error message. It seems those attribute numbers
should be in a lower range, because if I start from 1 , and I don't get the
message in question. But in this case, the attribute becomes unknown
resulting in having not applied while user authentication.

Is there a way to overcome this problem ?


Salim Engin
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Freeradius-Users mailing list