need help for adding VSA dictionary in Freeradius 2.1.6

Alan DeKok aland at
Fri Sep 11 11:40:46 CEST 2009

Salim Engin wrote:
> I have problem in adding new VSA dictionary file into Freeradius 2.1.6.
> Below you can find the steps I performed;
> According to my analysis, freeradius does not like the hex values in the
> VSA dictionary file i.e : 0x0700 .

  In 2.1.x, it can handle hex values just fine.

> So I tried to make it decimal which
> is 1792 but still getting the same error message. It seems those
> attribute numbers should be in a lower range, because if I start from 1
> , and I don't get the message in question. But in this case, the
> attribute becomes unknown resulting in having not applied while user
> authentication.

  The default VSA format is an 8 bit "type" field.  0x0700 doesn't fit
within an 8-bit field.

  What is the format for Alcatel-Esam attributes?  Do you have
documentation from Alcatel saying what the format is, or a dictionary
from another vendor describing the format?

  Alan DeKok.

More information about the Freeradius-Users mailing list