wifi + freeradius + mysql + eap/tls

specr ellanosv at gmail.com
Thu Nov 17 21:12:25 CET 2011

Hi guys,

I've just installed a freeradius+mysql on a debian 6.0.3, first test from
localhost with radtest and mysql user auth (radcheck table) worked well, 2nd
test with radeaptest with mysql and md5 eap method worked well too, but I
don't find a way to make it work with eap+tls:

Here's my error output:

*[peap] <<< TLS 1.0 Alert [length 0002], fatal unknown_ca 
TLS Alert read:fatal:unknown CA
    TLS_accept: failed in SSLv3 read client certificate A
rlm_eap: SSL error error:14094418:SSL routines:SSL3_READ_BYTES:tlsv1 alert
unknown ca
SSL: SSL_read failed inside of TLS (-1), TLS session fails.
TLS receive handshake failed during operation*

For what I've read, either I must create my own certs for eap+tls or I can
disable TLS, for the 1st, I've followed 'n' guides on the web but none seems
to work for me and for the second, I just dont find where to disable the eap
with TLS.

I don't really want to use TLS, so if you help me to disable TLS, it'll be
fine for me.

Please, I'd very much apreciatte your assistance.

Thanks in advance.

View this message in context: http://freeradius.1045715.n5.nabble.com/wifi-freeradius-mysql-eap-tls-tp5002331p5002331.html
Sent from the FreeRadius - User mailing list archive at Nabble.com.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freeradius.org/pipermail/freeradius-users/attachments/20111117/df44f554/attachment.html>

More information about the Freeradius-Users mailing list