CentOS 6.3 and FreeRadius - can't authenticate to Unix

Alan DeKok aland at deployingradius.com
Tue Oct 30 08:04:06 CET 2012

Jacobs, Joseph wrote:
> I’m trying to set up Freeradius to authenticate against the local Linux
> user accounts.
> joe2 Auth-Type := System   (I’ve tried this with both := and =)

  Don't do that.

> bob Cleartext-Password := "hello"



> [files] users: Matched entry bob at line 8

  That makes sense.

> Sending Access-Accept of id 124 to port 54241

  So that works.

> When I run  “radtest joe2 secret localhost 0 testing1234”
> ++[unix] returns notfound

  That's pretty definitive.  The user isn't in /etc/passwd, or
/etc/shadow.  Or, the server can't read it.

> [files] users: Matched entry joe2 at line 6

  That entry is wrong, delete it.

> One of the steps involved putting the group for freeradius to be
> “shadow” but there is no “shadow” group in the group file in CentOS 6.3.

  That's fine.  If you're running the server as root, that isn't necessary.

> I also did confirm that I can log into my server using joe2 / secret
> password.

  Well, FreeRADIUS asks the system for "joe2"s password.  It says "not

  Alan DeKok.

More information about the Freeradius-Users mailing list