MAC Authentication with FreeRadius

Bouchra Badri bouchra.badri at
Thu Feb 28 16:02:04 CET 2013

Sorry to bring this up again.
I tried to do as you said, and added this line :
 VMPS-VLAN-Name = "%{sql:select radius.maclist.vlanname from radius.maclist
where radius.maclist.mac='%{VMPS-Mac}'}"
as well as this one : $INCLUDE /etc/raddb/sql.conf   ( don't know why, just
told my self it made sense if I want the above line to be queried)
I took the vmps file to sites-enabled so it runs as a virtual server.
I followed just what I needed from this link to create the database and
grant privileges...
However when I run radiusd I get this ( in the image)
I know it's probably elementary, but it's that English isn't my forte so I
don't get what the debug says or why

Oh and for the first option ( MAB ) I get this error when I try it :

*ERROR: No authenticate method ( Auth-Type) found for the request :
Rejecting the user*
*Failed to authenticate the user*
*Using Post-Auth-Type Reject*
*#Executing group from file /etc/raddb/sites-enables/default*
*+-entering group REJECT {...}*
*[attr_filer.access_reject] expand : %{User-Name} -> 001e68599e21*
*attr_filer : Matched entry DEFAULT at line 11*
*++ [attr_filter.access_reject] returns updated*
My users file has this :

001e68599e21 Auth-Type:= ACCEPT  , User-Password == "001e68599e21"
        Tunnel-Type = VLAN,
        Tunnel-Medium-Type = IEEE-802,
        Tunnel-Private-Group-Id = 4

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: vmps.png
Type: image/png
Size: 31186 bytes
Desc: not available
URL: <>

More information about the Freeradius-Users mailing list