MAC Authentication with FreeRadius

Arran Cudbard-Bell a.cudbardb at
Thu Feb 28 20:05:19 CET 2013

On 28 Feb 2013, at 10:02, Bouchra Badri <bouchra.badri at> wrote:

> Hello,
> Sorry to bring this up again. 
> I tried to do as you said, and added this line : 
>  VMPS-VLAN-Name = "%{sql:select radius.maclist.vlanname from radius.maclist where radius.maclist.mac='%{VMPS-Mac}'}"
> as well as this one : $INCLUDE /etc/raddb/sql.conf   ( don't know why, just told my self it made sense if I want the above line to be queried)
> I took the vmps file to sites-enabled so it runs as a virtual server. 
> I followed just what I needed from this link to create the database and grant privileges...
> However when I run radiusd I get this ( in the image)
> I know it's probably elementary, but it's that English isn't my forte so I don't get what the debug says or why

At a guess i'd say you're not using the SQL module anywhere else in the server, and you need to add it to radiusd.conf in instantiate so it actually gets loaded...

More information about the Freeradius-Users mailing list