Some inconsistencies concerning OpenSSL include configuration in FRS 3

Dr. Andreas Rieke rieke at
Mon Jul 28 20:49:41 CEST 2014

Alan DeKok wrote:
> Dr. Andreas Rieke wrote:
>> They do - today I have also tested that for the LDFLAGS, and this works, too. If you pass the OpenSSL directories twice to the main configure script, everything works great:
>   <sigh>  The point is that people should NOT have to do that.
I agree to you - however, this is what you have suggested. In your last email, you wrote
> The issue is that the CPPFLAGS are *supposed* to be passed from the
> main configure script to the lower-level ones.
I thought that you are not sure about that and that you have asked me to test it - I tested that and the LDFLAGS, too, and it worked without any modifications. For that reason, there was no need for me to test your suggestions.
>> I checked the config.log files and the shared objects with ldd - all headers are found and the correct library files are used. For that reason, everything is great for me - thank you very much for your help,
>   And you didn't test the "configure" script as I requested.
I did not do the tests you suggested because things already work - why should I test something which is not required? Or did I misunderstand something?
>   It's nice to know you have a solution which works for you, is unusual,
> undocumented, and you don't care to help other people, so that they
> don't run into the same problem.
I have documented everything in my email in order to help other people, I have tested everything until things worked, and for these reasons, I do not think that your statement is true. I will run the tests you requested tomorrow - although I do not understand for what purpose,

best regards,


More information about the Freeradius-Users mailing list