Android 2.3.5 supplicants failing after upgrade to FreeRADIUS 2.2.5 from 2.2.0

Robert Franklin rcf34 at
Tue Jun 3 01:56:31 CEST 2014

On 2 Jun 2014, at 21:54, Adam Bishop <Adam.Bishop at JA.NET> wrote:

> And also a wpa_supplicant bug, so unrelated to your android issue:

OK - I'll take a look at this tomorrow, thanks.  I would like to see eapol_test running to confirm things are basically OK.

> Your android issue looks a lot like this though, have you eliminated this as a cause:

Reading that and the big thread it links to certainly all fits what we're seeing, although I'm not sure if where the EAP dialogue is aborting (prior to it saying the tunnel has been established) is where we would expect it to, if that was the the problem.

I've tried the various suggestions on that thread but none have worked for me on the test phone.  This includes installing the WiFi Advanced Configuration Editor and adjusting the details of the configuration, but they do keep resetting to the broken ones people describe.

So... the above problem seems likely, but I'm not sure why it's suddenly started occurring.  I think it's most likely changes to OpenSSL, perhaps as the reported SuSE version (0.9.8j) has some fixes from later versions backported, I believe.

I think we'll have to do some tests with this, although time may dictate we just put it down as an Android bug and say we can't resolve it.

Thanks for everyone's help but if you have something else, it's be welcome!

  - Bob

Bob Franklin   rcf34 at / +44 1223 748479
Networks, University Information Services, University of Cambridge

More information about the Freeradius-Users mailing list